Más problemas con NLTK

Después del problema anterior, decido probar con Python 2.7. Instalo NLToolkit en la carpeta de este, y pruebo el mismo  comando de antes.

"No module named yaml"

No sé qué es el módulo yaml, pero lo relaciono con PyAIML, que no lo he instalado. Así que le doy al enlace correspondiente en la sección downloads de nltk.org. Pero la instalación de PyAIML me exige Python 2.6.

En realidad hay PyAIML para las últimas versiones de Python, de hecho anteriormente instalé uno para Python 3. Pero ya que con Python 3 tuve problemas, no quiero meterme en berenjenales y decido mejor bajarme Python 2.6 y hacerlo todo como indiquen las instrucciones.

Con Python 2.6 voy un poco más lejos pero no mucho más, es decir, se abre el NLTK Downloader (a pesar de que se muestra un mensaje de error: DeprecationWarning: object.__new__() takes no parameters en el intérprete) , clico Download, baja el corpus, y cuando vuelvo al IDLE para introducir from nltk.book import*, me doy cuenta de que no hay “>>>” visible, de todas formas se puede escribir, así que voy allá pero no sirve de nada, se ha quedado inútil perdido y ya no puedo hacer nada más:

"Deprecation warning"

En fin, como siempre, mis tímidos acercamientos a procesos computacionales más complejos que abrir ventanas y arrastrar iconos, generan fuerte frustración.

Anuncios